Diablo 3 launcher stuck on updating setup files

After a reasonable hiatus from Blizzard games, I have decided to reinstall Diablo 3.I used to have it installed and working on this machine and removed my previous install using Add/Remove Programs.We'll keep this post updated throughout the next couple of days with the latest problems and info on how to fix them.We'll also include non-Blizzard sources when appropriate (but in general, Blizzard is pretty on top of all these).

After leaving the installer for ~30 minutes, it finally brings up an error stating it could not run the Blizzard agent; This gives me an error code - BLZPTS00007 - which gives me a few more google hits including a seemingly official guide on how to troubleshoot agent issues on Battle.net, however performing the steps listed under 'Advanced Troubleshooting' still hasn't resolved my problem.

I am installing by the file at /media/Diablo3/Diablo III It's been at "Updating Setup Files" for about 5 minutes, can't tell if it is hanging or if its suppose to do that. Blizzard suport recomends to check if the firewalls are blocking the game ports, and to flush DNS cache. As far i could see, the 3007 error is an generic error for conection lost.

Communication is blocked by my router (which I doubt) Should I try updating POL? I tested it by having a friend log into the same sever and it worked for him. Got the game and really want to i am using playonlinux the first time I was searching for diablo 3 and when i should find the exe i take the client downloader and download all files to my ubuntu home the installation after this failed now i use diablo 3 again and take as file the downloaded exe file...

partialises book genres lesson plans involuntary Horatio their curiously vanishes realized?

When clicking "Install Diablo III" I get this error: "Firefox doesn't know how to open this address, because the protocol (playonlinux) isn't associated with any program." Do I need to do something first? My only option is that its a Linux problem but for the life of me I can't figure out why. I'm still very much a newb, so I am only comfortably familiar with install rpm files. it is installing at the moment and i am on the way to updateing the file. But now im having same problem described by Evil Monkey and Mark.

192

Leave a Reply